KiXforms Forum Index KiXforms
The Forum for the KiXforms Community
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Quick Links 
Site News
Downloads
Documentation
Donations
Script Archive
Tracking Systems

Newbish, sorry

 
Post new topic   Reply to topic    KiXforms Forum Index -> KiXforms.NET Discussion
View previous topic :: View next topic  
Author Message
ggriffis
KiXforms Novice
KiXforms Novice


Joined: 02 Nov 2007
Posts: 2

PostPosted: Fri Nov 02, 2007 3:23 pm    Post subject: Newbish, sorry Reply with quote

Im moving users from kixforms.dll to Kix.Net. Will the following line of code suffice for this?
Code:
shell   @LDRIVE + '\kixforms.msi /norestart /quiet'


Previously, I checked the version and build of kixforms.dll and updated as necessary. Is that no longer necessary?

Thank you.
Back to top
View user's profile Send private message
pearly
KiXforms Aficionado
KiXforms Aficionado


Joined: 27 Jan 2004
Posts: 332

PostPosted: Fri Nov 02, 2007 5:05 pm    Post subject: Reply with quote

ggriffis, I check %SystemRoot%\system32\kixforms.system.dll so the .msi doesn't execute every time the script is run.
Back to top
View user's profile Send private message
Mart
KiXforms Regular
KiXforms Regular


Joined: 03 Oct 2005
Posts: 57
Location: Rotterdam - Netherlands

PostPosted: Thu Nov 08, 2007 8:55 am    Post subject: Reply with quote

Or deploy the MSI with a GPO.

All my systems get the kf.net installed with a GPO. It's very easy to upgrade to a new version this way, the installation only runs once and does not need things like runas or stuff like that.

_________________
Mart

- He's chained forever to a world that's departed.....It's not enough, it's not enough - Sorrow by Pink Floyd.
Back to top
View user's profile Send private message
ggriffis
KiXforms Novice
KiXforms Novice


Joined: 02 Nov 2007
Posts: 2

PostPosted: Wed Nov 28, 2007 1:58 pm    Post subject: Install Issues Reply with quote

Im having some initial issues with new workstations. I have a Windows XP SP2 computer, applied with the latest updates including .Net 3.0. I run the kixforms.msi as a domain administrator with no issues. I attempt to run my .kix script and it doesnt work. I can see a quick DOS window appear and then disappear. Ive attempted to uininstall and reinstall both .Net 3.0 and Kixforms. I attempted to reregister kixforms.system.dll but receive the following:
Quote:
kixforms.system.dll was loaded, but the DllRegisterServer entry point was not found. The file can not be registered.


Any help would be appreciated.

***After manually copying the kixforms.dll file to the \system32 directory and registering it, the script ran. Assume Ive done something wrong somehwere?***

***In continuing to answer my own issues, I removed kixforms.net from the computer and the script ran. Have to assume my form isnt a kixforms.net form and I should work to alleviate my ignorance?***
Back to top
View user's profile Send private message
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Fri Nov 30, 2007 12:19 am    Post subject: Reply with quote

Hi,

One cant register kixforms.system.dll using regsvr32.exe ... regsvr32.exe is only for the older standard COM components. Instead, one uses regasm.exe (register assembly) ... i used to have a sample command line for it kicking around ... anybody ? still digging.
Back to top
View user's profile Send private message
Jochen
KiXforms Devotee
KiXforms Devotee


Joined: 05 Mar 2003
Posts: 1204
Location: Stuttgart, Germany

PostPosted: Fri Nov 30, 2007 1:00 pm    Post subject: Reply with quote

I think it is

regasm /tlb:[path]kixforms.system.dll [/silent]

_________________
Jochen

Tell me, and I will forget.
Show me, and I may remember.
Involve me, and I will understand.
Back to top
View user's profile Send private message MSN Messenger
benny69
KiXforms Advocate
KiXforms Advocate


Joined: 30 Oct 2003
Posts: 567
Location: Lincoln, Ne

PostPosted: Fri Nov 30, 2007 1:53 pm    Post subject: Reply with quote

It was so long ago so I can't remember for sure but to register the .dll I think I used:

Regasm %SystemRoot%\System32\kixforms.system.dll /codebase


Then to create the .tlb I used:

Regasm %SystemRoot%\System32\kixforms.system.dll /registered /tlb:%SystemRoot%\System32\kixforms.system.tlb


Then to unregister the dll I used:

Regasm %SystemRoot%\System32\kixforms.system.dll /unregister

Here is the Regasm.exe zipped that I used:



RegAsm.zip
 Description:

Download
 Filename:  RegAsm.zip
 Filesize:  8 KB
 Downloaded:  2645 Time(s)


_________________
Wait don't order yet,... get KiXforms Designer .NET 2.0 (Beta)
KiXforms Designer .NET 2.0 (Beta)
Back to top
View user's profile Send private message Send e-mail
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Fri Nov 30, 2007 2:00 pm    Post subject: Reply with quote

Those look right. The big question/concern I had is ... registering the component this way - is it available to "all users" on the platform - or just to the user that registered it. I dont know the answer for sure - Jochen/Benny ?
Back to top
View user's profile Send private message
benny69
KiXforms Advocate
KiXforms Advocate


Joined: 30 Oct 2003
Posts: 567
Location: Lincoln, Ne

PostPosted: Fri Nov 30, 2007 2:05 pm    Post subject: Reply with quote

I have only used the 'AllUsers = 1' with the .msi like this:

KiXForms.msi AllUsers = 1

I don't think the 'AllUsers = 1' is a part of the .dll, think it is only part of the .msi. so I don't think it will work with the .dll, but I am not sure.

Can't remember if Regasm Kixforms.system.dll ends up in the HKLM so it might work for all users by default.

_________________
Wait don't order yet,... get KiXforms Designer .NET 2.0 (Beta)
KiXforms Designer .NET 2.0 (Beta)


Last edited by benny69 on Fri Nov 30, 2007 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail
Jochen
KiXforms Devotee
KiXforms Devotee


Joined: 05 Mar 2003
Posts: 1204
Location: Stuttgart, Germany

PostPosted: Fri Nov 30, 2007 2:06 pm    Post subject: Reply with quote

Now that I read Dale's suggestions I think I am plain wrong ... I did that only once and then dropped kf.net as for the long initial loading time, and went back to kf.classic Silenced

I shouldn't even look in here before I wrote my first kf.net app Mr. Green

_________________
Jochen

Tell me, and I will forget.
Show me, and I may remember.
Involve me, and I will understand.
Back to top
View user's profile Send private message MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    KiXforms Forum Index -> KiXforms.NET Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group