KiXforms Forum Index KiXforms
The Forum for the KiXforms Community
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Quick Links 
Site News
Downloads
Documentation
Donations
Script Archive
Tracking Systems

OpenFileDialog errors
Goto page 1, 2  Next
 
Post new topic   Reply to topic    KiXforms Forum Index -> KiXforms.NET Discussion
View previous topic :: View next topic  
Author Message
krabourn
KiXforms Aficionado
KiXforms Aficionado


Joined: 05 Mar 2003
Posts: 273
Location: San Antonio. TX

PostPosted: Sat Nov 12, 2005 3:45 pm    Post subject: OpenFileDialog errors Reply with quote

I have finally have gotten a chance to start playing with the .NET version and I have a problem.

I have installed version 3.1.24.0 and it appears that OpenFileDialog does not work.

Kixpad that comes in the samples and KFD both error.

I added @Error and @SError to kixpad.
Code:
$OpenFileDialog = $System.OpenFileDialog()
? @Error
? @SError
This is what I saw.
Code:
-2146233079
Error (317 / 13D) while retrieving error information for 80131509

The results from this just echo to the command prompt.
Code:
$OpenFileDialog.Filter = "Scripts (*.kix)|*.kix|All Files (*.*)|*.*"
$OpenFileDialog.InitialDirectory = ReadValueEx($REGKEY, "InitialDirectory", @CURDIR)

I think the problem is only with OpenFileDialog and maybe SaveFileDialog. I am thinking it is just me, but I am at a loss of what else to check.

_________________
Kelly
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Sat Nov 12, 2005 5:11 pm    Post subject: Reply with quote

And everything else you've tried appears to work ok eh.
Back to top
View user's profile Send private message
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Sat Nov 12, 2005 5:44 pm    Post subject: Reply with quote

If you have network drive mappings of any kind, try disconnecting them and try again ...
Back to top
View user's profile Send private message
krabourn
KiXforms Aficionado
KiXforms Aficionado


Joined: 05 Mar 2003
Posts: 273
Location: San Antonio. TX

PostPosted: Sat Nov 12, 2005 9:57 pm    Post subject: Reply with quote

I have written any real code yet. I was starting to play with the apps that have been written here.

I am on my home computer and there are no network drives.

_________________
Kelly
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Sat Nov 12, 2005 10:19 pm    Post subject: Reply with quote

Did you just install the .Net framework, or has it been on your machine for a while. Know what version your running ? 1.1 ? sp1 ?
Back to top
View user's profile Send private message
krabourn
KiXforms Aficionado
KiXforms Aficionado


Joined: 05 Mar 2003
Posts: 273
Location: San Antonio. TX

PostPosted: Sat Nov 12, 2005 10:35 pm    Post subject: Reply with quote

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

_________________
Kelly
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Sun Nov 13, 2005 12:23 am    Post subject: Reply with quote

Ok, i was running this:

Framework Version = 2.0.40607.42

Which was the prelease of 2.0. So i uninstalled that, then download the final release of 2.0, and now i'm at:

Framework Version = 2.0.50727.42

and this is what I got when running Kixpad:

C:\kixpad>kix32 kixpad
Scripts (*.kix)|*.kix|All Files (*.*)|*.*C:\kixpad

So your right - something is broken in the final build of 2.0 ... looking into ... much thanks for the report.
Back to top
View user's profile Send private message
krabourn
KiXforms Aficionado
KiXforms Aficionado


Joined: 05 Mar 2003
Posts: 273
Location: San Antonio. TX

PostPosted: Sun Nov 13, 2005 12:28 am    Post subject: Reply with quote

Phew!!! I was wondering if the version of .NET 2 was it, but I assumed someone else would have yelled already.
_________________
Kelly
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Sun Nov 13, 2005 12:43 am    Post subject: Reply with quote

Well its good and bad - something changed from the pre-release of 2.0 to the final - and i've been looking into it for the past 30 mins or so - its not looking too good - I cant create an instance of the OpenFileDialog for some reason - its pretty basic stuff, and it aint working.
Back to top
View user's profile Send private message
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Sun Nov 13, 2005 1:27 am    Post subject: Reply with quote

phew! fixed it. will post a new buld tomorrow or so.
Back to top
View user's profile Send private message
krabourn
KiXforms Aficionado
KiXforms Aficionado


Joined: 05 Mar 2003
Posts: 273
Location: San Antonio. TX

PostPosted: Sun Nov 13, 2005 2:55 am    Post subject: Reply with quote

HAHAHA!!! Laughing
_________________
Kelly
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Shawn
KiXforms Developer
KiXforms Developer


Joined: 22 Feb 2003
Posts: 1983
Location: Canada

PostPosted: Sun Nov 13, 2005 3:25 am    Post subject: Reply with quote

That seriously had me worried. I've been concerned about stuff breaking in .Net 2.0. Now that this is fixed, things are looking good.
Back to top
View user's profile Send private message
Lonkero
KiXforms Devotee
KiXforms Devotee


Joined: 13 Mar 2003
Posts: 1022
Location: Espoo, Finland

PostPosted: Mon Nov 14, 2005 4:12 am    Post subject: Reply with quote

single fix and you say things are looking good?

hmm...

_________________
Hammer
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
apronk
KiXforms Regular
KiXforms Regular


Joined: 28 Jun 2006
Posts: 53
Location: The Netherlands

PostPosted: Sun Oct 28, 2007 7:49 pm    Post subject: Reply with quote

Ehm, it's either broken again or still not fixed Smile
Code:

$OpenFileDialog1 = $System.OpenFileDialog()
? @ERROR
? @SERROR

returns:
-2147352567
[-2147352567/80020009] - Object reference not set to an instance of an object.)

This is using Microsoft .Net v2.0.50727
Kix 4.60, Kixforms .Net 3.0.1 Final
WinXP Pro with All updates.

_________________
Achieve inner peace through outer violence.
Back to top
View user's profile Send private message Visit poster's website
pearly
KiXforms Aficionado
KiXforms Aficionado


Joined: 27 Jan 2004
Posts: 332

PostPosted: Mon Oct 29, 2007 4:39 pm    Post subject: Reply with quote

apronk, I would recommend upgrading KF.NET to the latest version (3.2.14). I am using OpenFileDialog and do not have a problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    KiXforms Forum Index -> KiXforms.NET Discussion All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group